Wie können vorkompiliert bereitgestellte Module eingebunden werden?

Für die verschiedenen PHP-Editionen stellt McAc.net zahlreiche Module bereits standardmäßig in PHP einkompiliert zur Verfügung. Einige PHP-Module werden hingegen nicht einkompiliert bereitgestellt, können jedoch extern in PHP eingebunden werden.

Viele dieser Module stellen wir bereits vorkompiliert zur Verfügung, so dass eine einfache und schnelle Einbindung vorgenommen werden kann. Zudem nimmt McAc.net bei Aktualisierungen von PHP automatisch eine Neukompilierung der jeweiligen Module vor, ohne dass Ihrerseits ein manuelles Eingreifen erforderlich wäre!

Um vorkompilierte Module in PHP einzubinden, erstellen Sie im php.ini-Editor unter der jeweiligen Domain bitte einfach einen entsprechenden Eintrag. Hierbei sind die folgenden Angaben erforderlich:

1. Angabe des Modul-Verzeichnisses

Alle für eine bestimmte Edition von PHP zusätzlich verfügbaren Module befinden sich in einem gemeinsamen Verzeichnis. Dieses Verzeichnis muss in der php.ini-Datei angegeben werden, um beim Aufruf von PHP sicherzustellen, dass an der richtigen Stelle nach dem zu ladenden Modul gesucht wird. Nachfolgend finden Sie die Verzeichnisse für die unterschiedlichen bei McAc.net verfügbaren Editionen von PHP:

  • /usr/local/lib/php_modules/4-STABLE
  • /usr/local/lib/php_modules/5-STABLE
  • /usr/local/lib/php_modules/5-53STABLE
  • /usr/local/lib/php_modules/5-54STABLE
  • /usr/local/lib/php_modules/5-55STABLE
  • /usr/local/lib/php_modules/5-55LEGACY
  • /usr/local/lib/php_modules/5-55LATEST
  • /usr/local/lib/php_modules/5-56STABLE
  • /usr/local/lib/php_modules/5-56LATEST
  • /usr/local/lib/php_modules/5-56LEGACY
  • /usr/local/lib/php_modules/7-70STABLE
  • /usr/local/lib/php_modules/7-70LATEST
  • /usr/local/lib/php_modules/7-71LATEST

Für die LIGHT- und EXTENDED-Editionen können die Verzeichnisse der jeweils übergeordneten Edition verwendet werden. Möchten Sie beispielsweise für die Edition „5-56LATEST-EXTENDED“ Module extern einbinden, so verwenden Sie bitte das Verzeichnis der Edition „5-56LATEST“.

Der Eintrag in die php.ini-Datei ist wie folgt vorzunehmen:

extension_dir=“/usr/local/lib/php_modules/5-56LATEST

Möchten Sie für eine andere PHP-Edition die Moduleinbindung vornehmen, so passen Sie die Pfadangabe im genannten Beispiel bitte einfach entsprechend an.

2. Angabe des einzubindenden Verzeichnisses

Neben der Angabe des Modul-Verzeichnisses ist es erforderlich, in der php.ini-Datei das Modul anzugeben, welches extern eingebunden werden soll. Dieser Eintrag ist wie folgt vorzunehmen:

extension=“openssl.so“

In diesem Beispiel wird das openssl-Modul eingebunden, bitte ersetzen Sie das Wort „openssl“ einfach durch den Namen des Moduls, welches Sie gerne einbinden möchten. Eine Liste der verfügbaren Module können Sie über den nachfolgenden FAQ-Beitrag in Erfahrung bringen.

Beachten Sie bitte, dass über den php.ini-Editor lediglich ein einzelnes zusätzliches PHP-Modul eingebunden werden kann. Sollen mehrere PHP-Module gleichzeitig eingebunden werden, so ist dies ausschließlich über das manuelle Anlegen einer eigenen php.ini-Datei möglich.

Selbstverständlich können Sie ein Einbinden von Modulen auch mittels Erstellen bzw. Editieren von php.ini-Dateien ohne die Verwendung des php.ini-Editors vornehmen. Nach manueller Anlage der php.ini-Datei nehmen Sie dort bitte einen Eintrag wie weiter oben beschrieben vor, um die gewünschten Module einzubinden.

ACHTUNG: Bitte beachten Sie, dass wir uns bemühen, stets auf die ordnungsgemäße Funktionalität der zusätzlich vorkompilierten Module zu achten, wir hierfür jedoch keine Gewährleistung übernehmen können.